Home > Uncategorized > Instalando o VMware-Server 1.0.5 no Ubuntu 8.04 Hardy Heron ( Atualizado )

Instalando o VMware-Server 1.0.5 no Ubuntu 8.04 Hardy Heron ( Atualizado )

Surgiram alguns erros ao tentar instalar o VMware-Server no Ubuntu 8.04 usando o kernel 2.6.24-16 e para corrigi-los segui os seguintes passos:

Instalei alguns pacotes que não são instalados por padrão

sudo aptitude install build-essential linux-headers-$(uname -r) xinetd

Faça a instalação do VMWare normalmente. Se um erro ocorrer baixe o patch e instale-o.

cd ~/tmp/vmware-any-any-update116

sudo ./runme.pl

Após aplicar o patch e instalar o vmware foi necessário criar os seguintes links simbólicos para que ele funcionasse corretamente:

sudo ln -sf /lib/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1
sudo ln -sf /usr/lib/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0

Fonte

  1. Wilson Jr
    04/19/2008 at 11:50 PM

    Po, nao podia deixar de agradecer, esse sim é o verdadeiro espirito do software livre, valeu pela dica.

    []’s
    Junior

  2. Junior Madrigal
    04/22/2008 at 8:37 PM

    Por que será que está dando errado?

    madrigal@tamoio:~/temp/vmware-any-any-update116$ sudo ./runme.pl
    Unable to open the installer database /etc/vmware/locations in read-mode.

    Execution aborted.

  3. 04/22/2008 at 11:02 PM

    Olá Junior,

    Antes de rodar o patch faça a instalação do vmware.

    Sds,

    Alex

  4. Luiz Duarte
    04/23/2008 at 8:50 PM

    Ele não cria mais um atalho em Aplicações->Ferramentas do Sistema?

  5. Elton Simões Baptista
    04/24/2008 at 8:15 AM

    Muito obrigado, aki funcionou direitinho

    Ubuntu Hardy Heron / Notebook Acer Aspire 5610

  6. Felipe
    04/27/2008 at 1:54 PM

    Valeu cara.
    Penei muito para conseguir instalar o vmware aqui. Mas esse tutorial juntamente com esse

    https://help.ubuntu.com/community/VMware/Server/AMD64?action=fullsearch&value=linkto%3A%22VMware%2FServer%2FAMD64%22&context=180

    me ajudar a instalar o VMware no Hardy.

  7. 04/27/2008 at 6:06 PM

    Valeu a dica!

    Na minha instalação ele tb não criou o atalho em Aplicações->Ferramentas do Sistema Luiz, mas criou em Aplicações->Outros

  8. Emerson
    04/28/2008 at 2:25 PM

    Parabéns…me ajudou pacas…

  9. 05/01/2008 at 12:27 AM

    Obrigado pela dica penguim!😉

    Não consegui de primeira, mas não desisti e refiz alguns passos de outros tutoriais e o seu novamente, até que finalmente funcionou.😀
    Estava quase voltando pro VirtualBox (mas tenho um problema com ele quanto ao acesso de fora pra dentro da VM e queria testar o Vmware).

    Agora vou poder estudar com calma.

    Mais uma vez, obrigado e parabéns pelo site. o/

  10. Júnior Madrigal
    05/02/2008 at 11:53 AM

    Este tutorial parece ser só pra quem já sabia instalar na versão anterior.
    Poderiam me indicar um tutorial pra quem não sabe instalar o VMWare? Os que eu encontrei pela internet não deram certo, talvez devido à versão diferente do kernel.

  11. 05/04/2008 at 6:36 PM

    Brigadão pela dica, mano. Seu tutorial é ótimo e me foi muito útil. Parabéns!

  12. Júnior Madrigal
    05/06/2008 at 9:43 PM

    Consegui instalar o VMWare graças a ajuda desta página e dessa outra: http://www.vivaolinux.com.br/dicas/verDica.php?codigo=9636&comentario=?comentario=

    Mas estou com esses dois problemas:

    Não apareceu o programa no menu Aplicações>Ferramentas do Sistema, pra poder abrir, preciso abrir o terminal e digitar vmware, deve estar faltando instalar algo.

    Uma outra coisa, aproveitei o vmware que eu tinha em outra partição, mas ao abrir, não reconhece o driver de cd, aparece a mensagem quando tento montar:
    Unable to open host CD-ROM drive “/dev/hdd”: No such file or directory.
    Failed to connect virtual device ide1:0.

    Agradeço se puderem me auxiliar a concluir estes detalhes.

  13. 05/09/2008 at 10:18 AM

    Cara… muito bom vlw…. vc é o cara

  14. Adriano
    05/14/2008 at 7:38 PM

    Olá

    Eu já estava com vmware server instalado no meu Ubuntu 7.10 entao após a atualização para o 8.04 ele não funcionou mais, mas não exibe nenhuma mensagem de erro.
    Alguma sugestão?

  15. Claudio Cardozo
    05/15/2008 at 10:40 AM

    Tbm tinha o 1.5 instalado no gutsy, qdo fui pro hardy, deixou de funcionar; e fiquei tentando usar o vmware 2.0 beta, mas ele mata a maquina. Esse tutorial me salvou! urraaa!

    vlw mto!

    abs

  16. 05/15/2008 at 12:34 PM

    Olá Adriano,

    Execute sudo vmware-config.pl

    [ ]’s

    Alex

  17. Peace
    05/16/2008 at 9:44 AM

    Olá amigo, valeu pela dica!
    Me quebrou um galho enorme! hehehe

    Grande abraço,

    Tiago Lima

  18. Otávio
    05/22/2008 at 3:12 AM

    cara…. muito obrigado! eu precisava dessa dica🙂

    abração!

  19. Fernando Patzlaff
    05/25/2008 at 10:34 PM

    funcionou perfeitamente…tks!

  20. Raphael R. O.
    05/28/2008 at 1:57 PM

    Olá penguim! consegui instalar o vmware aqui com esta dica, porem quando vou iniciá-lo, da o erro :

    /usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4′ not found (required by /usr/lib/libcairo.so.2)

    /usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0′ not found (required by /usr/lib/libstdc++.so.6)

    Já tentei criar links simbílicos para estes arquivos na /usr/lib mas mesmo assim nao funcionou. Pode me ajudar ?

    abçs
    Raphael

  21. Ricardo - L
    06/20/2008 at 5:08 PM

    Muito útil esta informacao.
    Parabéns pela atitude de plublicar a solucao.

    Abracos,

  22. jbjares
    07/07/2008 at 4:39 PM

    Muito Bom!
    Muito Obrigado!

  23. Luis
    08/03/2008 at 7:52 PM

    Obrigado!!

    Meu kernel é o 2.6.24-19 e eu não conseguia resolver o problema.. esse primeiro passo do build-essencial foi o que resolveu, mas o patch any-any é o 117c.

    Hoje vou poder dormir!!

    eeeee

  24. 09/27/2008 at 7:36 AM

    Olá a todos,
    Eu escrevi um artigo muito detalhado sobre
    como instalar o vmware server no ubuntu 8.04 server e no debian etch. A diferença é que a versão do meu tutorial é a 1.0.6 e não precisei do vmware-any-any, além de ser super detalhado.

    Raphael R. O. – tem a solução pra esse problema seu lá.

    Abraços

  25. Thiago Alexandre
    01/16/2009 at 1:20 PM

    Obrigado por este post pois foi muito util para mim.
    Parabens.

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: