Home > Uncategorized > Instalando a placa Atheros ath5x no Ubuntu 8.04 e 8.10
  1. leandro
    08/27/2008 at 7:26 PM

    Olá eu sou iniciante em linux e nao estou conseguindo instalar o driver.
    Salvo ele na área de trabalho executo

    tar zxvf madwifi-hal-0.10.5.6-r3698-20080604.tar.gz

    aparece o seguinte erro:

    lsbarros@lsbarros:~$ tar zxvf madwifi-hal-0.10.5.6-r3698-20080604.tar.gz
    tar: madwifi-hal-0.10.5.6-r3698-20080604.tar.gz: Não é possível open: Arquivo ou diretório inexistente
    tar: Erro não é recuperável: saindo agora
    tar: Child returned status 2
    tar: Saída por erro atrasada pelos erros anteriores

    o que estou fazendo de errado?

    Fico grato se puder me ajudar.

  2. 08/28/2008 at 8:52 AM

    Leandro, me parece que ao executar o comando tar você não está posicionado no mesmo diretório (Área de Trabalho) em que o arquivo se encontra, execute antes:

    cd ~/”Área de Trabalho”

  3. 08/28/2008 at 8:52 AM

    Blz Alex, promessa cumprida !

  4. 08/29/2008 at 8:27 AM

    Alguem sabe me informar o modelo mais exato da placa?
    Eu tenho aqui um note HP, com o kernel 2.6.24-18 funciona legal o driver madwifi

    mas com os ultimos que sairam nada =/
    alguma ideia?
    Abraco!

  5. capi etheriel
    08/30/2008 at 4:33 PM

    toda vez que vc der um update no kernel, vc vai ter que repetir o “make && sudo make install” (no mesmo folder, logico).
    pra melhorar um pouco o tutorial, que tal colocar wget antes do endereço do driver? assim vc baixa ele pelo terminal, de uma vez…
    a propósito, eu instalei outra atheros praticamente da mesma forma… desligando o hal e baixando o madwifi driver. só que eu usei o madwifi-ng-r2756+ar5007
    qual o certo pra sua placa atheros eu nao saberia dizer. eu segui um tutorial no ubuntu procurando pela minha placa…

  6. Junior
    09/25/2008 at 4:53 PM

    Checking requirements… ok.
    Checking kernel configuration… ok.
    make -C /lib/modules/2.6.24-19-generic/build SUBDIRS=/home/junior/Área de Trabalho/madwifi-hal-0.10.5.6-r3698-20080604 modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.24-19-generic’
    make[1]: *** No rule to make target `de’. Stop.
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-19-generic’
    make: ** [modules] Erro 2
    alguem poderia me dizer que erro este ai em cima

    e com que eu faço para conserter ele

  7. sky
    09/27/2008 at 6:01 PM

    amigo o problema esta no nome do diretorio que vc se encontra.. mova ele pro seu home e tente compilar novamente

  8. Junior
    09/29/2008 at 6:04 PM

    bem como que eu faço pare resolver iste erro aonde que eu tenho que colocar eChecking requirements… ok.
    Checking kernel configuration… ok.
    make -C /lib/modules/2.6.24-19-generic/build SUBDIRS=/home/junior/Área de Trabalho/madwifi-hal-0.10.5.6-r3698-20080604 modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.24-19-generic’
    make[1]: *** No rule to make target `de’. Stop.
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-19-generic’
    make: ** [modules] Erro 2
    alguem poderia me dizer que erro este ai em cima

    e com que eu faço para conserter ele

  9. Pedro Filipe Vieira
    10/31/2008 at 6:21 PM

    Junior,
    é isso que o sky disse.
    copie o arquivo pro seu home….

    cd
    cp ~
    cd ~

    daki em diante vc segue o fluxo normal como ja postado pelo penguim…
    oq eu acho q deve ser é q ele nao aceita diretorio com espaço ou talvez algum caracter especial…. eu tb tive esse problema e resolveo quando eu levei tudo pro meu home….
    se vc nao entendeu os comandos… entao copie do jeito q vc sabe fazer para alguma pasta q no caminho completo nao tenha espaço e nenhum caracter especial….
    eu consegui… boa sorte para vc…

  10. Pedro Filipe Vieira
    10/31/2008 at 6:24 PM

    ops deu problema nos comandos…
    é exatamente isso q vc tem q fazer…..

    cd home/junior/Área de Trabalho/
    cp madwifi-hal-0.10.5.6-r3698-20080604.tar.gz ~
    cd ~

  11. Will
    12/25/2008 at 10:36 PM

    Sou iniciante também no Linux. Instalei o Ubuntu, com tema do MAC OS X. Só faltava funcionar o wireless. Graças a ti, agora está tudo funcionando redondinho. Valeu amigo, parabéns pelo Blog!

  12. Andre
    02/11/2009 at 3:24 PM

    Valeu Alex,

    Muito obrigado pela dica. Funcionou perfeitamente

  13. Mauro
    02/17/2009 at 8:40 PM

    Pessoal, o vosso problema talvez seja o mesmo que o meu mas que eu soube resolver. As drivers ja nao a data nem a referencia das que aparecem no codigo fornecido, leiam bem a seguir ao tar que fazem, fazendo-o sem a parte do “r3698”, ou seja, a seguir ao hifen escrevam apenas de “current” para a frente. depois no change directory tem de escrever o rXXXX e a data conforme aparece nos ficheiros acima descompactados.

    Boa sorte.

    Um abraço

  1. 08/26/2008 at 10:33 AM

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: